您的当前位置:首页HDU 1161Eddy's mistakes

HDU 1161Eddy's mistakes

来源:锐游网
Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter.
 

Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.
 

Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
 

Sample Input
  
  
weLcOmE tO HDOj Acm 2005!
 

Sample Output
  
  
welcome to hdoj acm 2005!
简单的水题,就是把大写的字母换成小写
#include<stdio.h>
#include<string.h>
char a[1001];
int main()
{
	while(gets(a)!=NULL) {
		int n=strlen(a); 
	    for(int i=0;i<n;i++){
		if((a[i]>='A') && (a[i]<='Z')){
			a[i]+=32;
			printf("%c",a[i]);
		}else{
			printf("%c",a[i]);
		} 		
	    }
	    printf("\n");
	}	
}
代码较丑

因篇幅问题不能全部显示,请点此查看更多更全内容

Top